KKP 212 Installed in Win98SE - One Database fails to Open

The old version of our genealogy database program.

Moderator: Nick Hunter

Rodney Fry
Posts: 40
Joined: Tue Jan 17, 2006 10:38 pm
Location: Crowthorne, Berks

KKP 212 Installed in Win98SE - One Database fails to Open

Post by Rodney Fry » Fri Jul 27, 2007 6:40 pm

Just got round to installing updates for KKP v212 and TD v311 into my Win98SE system. All installed quickly and without problems - glad Win98 has not been forgotten!
Trees all appear to be OK and all the KKP databases tried so far, bar one, seem to be OK.

Trying to open this database via the Open Database dialogue window, highlighting the name as usual, I get an immediate message on clicking Open button:
"Error in opening database in H:\Kith & Kin Pro\Data\Kent\[name]"

All the other databases in this path in the Kent folder open OK.

I have copied the database to a floppy and tried on my laptop which still has KKP v211. The database opened OK in this case.

Could you advise if this is a case for the Borland database Fix Utility which is listed under KithKin Pro programs, or is it some other problem?

Thanks in advance.

Nick Hunter
Posts: 669
Joined: Sun Dec 18, 2005 9:36 am
Location: SpanSoft, Scotland

Post by Nick Hunter » Sat Jul 28, 2007 9:16 am

It seems strange that the same database will open OK on your laptop running K&KP V2.1.1. The only change to V2.1.2 was to fix the missing "Database | Delete" menu item.

If you email the database to support@spansoft.org we will look at it in V2.1.2 to see if it is the new version causing the problem but I suspect it must be something else.