Error Message on New Installation

Our genealogy database program.

Moderator: Nick Hunter

Post Reply
mimram
Posts: 3
Joined: Tue Dec 18, 2012 7:02 am

Error Message on New Installation

Post by mimram » Tue Dec 18, 2012 7:13 am

I have just intalled V3.2 on a new machine (Win 7 64 bit) and imported my data. The data appears to have imported OK but when I click on an individual i get the message "Field 'Personcode' is not in the current index".

If I click OK to the message, it then allows me to view the persons data.

Any suggestion how I can remove this message.

Ian Grant

Nick Hunter
Posts: 649
Joined: Sun Dec 18, 2005 9:36 am
Location: SpanSoft, Scotland
Contact:

Re: Error Message on New Installation

Post by Nick Hunter » Tue Dec 18, 2012 9:10 am

Hi,

Sorry to hear that you are having problems with Kith and Kin Pro.

The PersonCode field is in the Aliases table. This suggests that there is some form of corruption in the Aliases files. In K&KPro, please try using "File | Database | Repair" and then "File | Database | Pack" which may fix the problem.

mimram
Posts: 3
Joined: Tue Dec 18, 2012 7:02 am

Re: Error Message on New Installation

Post by mimram » Tue Dec 18, 2012 6:18 pm

Thanks Nick, I have tried your suggestion but it hasn't cured the problem. The database I am getting this problem on is very tiny and it would not be too much work to recreate it from scratch. Unless of course you have any more suggestions.

Nick Hunter
Posts: 649
Joined: Sun Dec 18, 2005 9:36 am
Location: SpanSoft, Scotland
Contact:

Re: Error Message on New Installation

Post by Nick Hunter » Wed Dec 19, 2012 8:57 am

Hi,
The next thing to try would be to export the database as a GEDCOM file (File | Export GEDCOM file) and then create a new database and import the GEDCOM file back into it.

mimram
Posts: 3
Joined: Tue Dec 18, 2012 7:02 am

Re: Error Message on New Installation

Post by mimram » Wed Dec 19, 2012 12:52 pm

Thank you, that worked a treat!

Post Reply