GEDCOM output not standard-compliant

Our genealogy database program.

Moderator: Nick Hunter

Post Reply
davep
Posts: 5
Joined: Thu Apr 23, 2009 5:04 pm

GEDCOM output not standard-compliant

Post by davep » Sun Nov 22, 2009 10:27 am

A minor niggle, but the GEDCOM output does not comply with the v5.5 standard, available for example at:
http://homepages.rootsweb.ancestry.com/ ... 5gctoc.htm

The problem is in the DATE field in the header, for example in

Code: Select all

0 HEAD
1 SOUR KITHKIN_PRO
2 VERS 3.0.6
2 NAME Kith and Kin Pro
2 CORP SpanSoft
3 ADDR E-mail: Support@spansoft.org
3 PHON +44 (0)1592 743110
1 DEST FILE
1 DATE 08/11/2009
1 SUBM @U1@
1 FILE all.ged
1 GEDC
2 VERS 5.5
2 FORM LINEAGE-LINKED
1 CHAR UTF-8
the date should be in the <DATE_EXACT> format, in this case "08 NOV 2009".

The incorrect format causes a warning when the GEDCOM file is imported into PHPGedView.

donne
Posts: 76
Joined: Wed Dec 28, 2005 12:46 pm
Location: UK
Contact:

Post by donne » Sun Nov 22, 2009 10:43 am

I also use PHPGedView and I notice that the date of the imported GEDCOM generated from KKPro is never set correctly - only the year is displayed. Could this issue be related? - I've never managed to work out the reason.

Nick Hunter
Posts: 672
Joined: Sun Dec 18, 2005 9:36 am
Location: SpanSoft, Scotland
Contact:

Post by Nick Hunter » Mon Nov 23, 2009 8:08 am

Hi,
Thanks for pointing this out. We will get it fixed in the next release.

donne
Posts: 76
Joined: Wed Dec 28, 2005 12:46 pm
Location: UK
Contact:

Post by donne » Wed Nov 25, 2009 5:54 pm

For what it's worth, editing the creation date format as indicated by davep certainly solves my problem with PHPGedView - a work-around until the next release arrives.

Post Reply