Another DB converter problem

Our genealogy database program.

Moderator: Nick Hunter

Post Reply
Posts: 4
Joined: Mon May 18, 2009 12:10 pm

Another DB converter problem

Post by Richard_42 » Mon May 18, 2009 12:32 pm

I've just downloaded and registered V3.
I've tried to run the DB converter ( as administrator - I'm on Vista ) and get an error box on loading, saying

"There is a problem with the Borland Database Engine (BDE). please try re-installing Kith and Kin Pro V1 or V2.
The error is: Could not find object."

I had used my V2 this morning ( before installing V3 ) sucessfully - however when I try to run it now I get an error window on loading, saying

"An error occured while attempting to initialize the Borland Database Engine ( error $2501 )"

I'm not sure where my V2 program disc is, is there any other solution, and what has caused my working V2 to stop ?

BTW my PC is backedup with Ghost so if you can tell me what files to restore I could do that



Nick Hunter
Posts: 666
Joined: Sun Dec 18, 2005 9:36 am
Location: SpanSoft, Scotland

Post by Nick Hunter » Mon May 18, 2009 9:27 pm

Hi Richard,

Sorry to hear that you are having problems with the conversion utility.

Please try running K&KPro2 in administrator mode. You could also try the conversion utility in WinXP compatibility mode.

If you need to reinstall the BDE it is in C:\Program files\Common files\Borland shared\BDE". If you need a complete reinstall, there is a copy of the last K&KPro2 on the Downloads page at
If you are going to reinstall K&KPro2 please delete the BDE folder first.

If you have no pictures in your database, you may find it easier to export the database as a GEDCOM file. Please remember to use the "Receiving system = Kith and Kin Pro" option.

Posts: 4
Joined: Mon May 18, 2009 12:10 pm

Post by Richard_42 » Tue May 19, 2009 9:36 am

Hi Nick,

Thanks for the reply.

I loaded V2 as administrator and it loaded, but using the demo DB not mine.
I then closed it ( not going into my DB ) and the conversion program then worked OK.
and now V3 works OK :D

It may be worth noting that although the sample DB for V2 was in it's install location, my DB's are on a diferent disc. I wonder if this is causing the problem

Thanks for you help


Post Reply