Page 1 of 1

database conversion problem

Posted: Tue May 12, 2009 5:27 pm
by duke723
Nick - I just downloaded and registered V3 this morning. When I try to convert my K&K Pro V2 databases I get a message telling me "The database "C:...." does not appear to be a valid Kith and Kin Pro database." These file work fine in V2. I'm using Vista SP1. What to do?

Regards, Jim Schneider

Posted: Tue May 12, 2009 8:03 pm
by Nick Hunter

Sorry hear that you are having problems converting your database to V3.

We have had one other similar report from a user but when he sent us the V2 database to look at, we were able to convert it without any errors.

I suspect that the problem might be to do with the location of the V2 database. Please try copying the V2 database folder into the root of the C drive, eg. C:\MyV2Database. Then try the V3 conversion utility again using the copied database folder as the source.

Posted: Tue May 12, 2009 8:53 pm
by duke723
That doesn't seem to make any difference. I've tried several different data files in both locations with the same result. They are all fully functional in V2.

Posted: Wed May 13, 2009 7:33 am
by Nick Hunter

Please send your database to and we will take a look at it. You do not need to send us the \Pictures folder.

Please be aware that in Vista using Virtualization, any files stored in the "Program files" folder hierarchy will be partly stored in the equivalent folder in "C:\Users\<username>\AppData\Local\VirtualStore\Program files". You need to check which version of the files is most up-to-date. If your database is stored in C:\KKProData then you don't need to bother about Virtualization.

Re: database conversion problem

Posted: Sat May 16, 2009 8:40 pm
by scatto

I was setting up KKP2/3 to do the conversions for someone else. Everything working for v2. Getting the same message for KK3ProConversion all v2 databases - not valid. Win XP SP2. BDENET all fine, tried copying V2 data to folders without spaces. Same error.

Took a guess and ran Borland database fix utility - verify and rebuild against the 1st folder in my C:\KKPro2Data all the DB files, this then ran through the v3 conversion and loads in v3 fine. Verify didn't report any faults. After that all the others converted working in v3 without needing the DB fix utility.