GEDCOM and sources

The old version of our genealogy database program.

Moderator: Nick Hunter

Locked
jayrae
Posts: 10
Joined: Sun Aug 13, 2006 12:19 am
Location: New Zealand

GEDCOM and sources

Post by jayrae » Sun Aug 05, 2007 11:41 am

I've been using a program called The Complete Genealogy Reporter to create narratives of what's in Kith and Kin Pro, but couldn't work out why it was showing multiple sources when I only had one in Kith and Kin Pro and, in some cases, showing I had a source (i.e. Death source) when I didn't have one!

I was about to complain to the creators of the program when I thought maybe I should look at the GEDCOM file that Kith and Kin Pro was creating first, sure enough, it's creating extra source's that don't exist!

The example below only has 1 Name, 1 Birth, 1 Christening and 1 Death source in Kith and Kin Pro but exports an extra Birth and Christening source reference (even though it's to the same source).

0 @I3369@ INDI
1 REFN 3369
1 NAME Ellen Betsy /HELM/
2 SOUR @S45@
3 QUAY 2
1 SEX F
1 BIRT
2 DATE 22 MAY 1843
2 SOUR @S45@
3 QUAY 2
2 SOUR @S45@
3 QUAY 2
1 CHR
2 PLAC Hinchinbrooke, Beauharnois County, Quebec, Canada
2 SOUR @S45@
3 QUAY 2
2 SOUR @S45@
3 QUAY 2
1 DEAT
2 PLAC California, USA
2 SOUR @S45@
3 QUAY 2
1 NOTE Living in Fresno, California, USA with her brother William Helm. 1870 Census.
1 FAMC @F1016@

Is there something I can do to fix this? Or is this a bug in Kith and Kin Pro?

Nick Hunter
Posts: 651
Joined: Sun Dec 18, 2005 9:36 am
Location: SpanSoft, Scotland
Contact:

Post by Nick Hunter » Mon Aug 06, 2007 11:33 am

It may be a problem in the Sources table indices. Do you see anything odd in the sources in K&KPro (eg. selecting a source reference gives something like "3 of 2 source references for this field")?

Try using "File | Database | Pack" and/or "Start | Programs | Kith and Kin Pro | Borland database fix utility".

jayrae
Posts: 10
Joined: Sun Aug 13, 2006 12:19 am
Location: New Zealand

Post by jayrae » Wed Aug 08, 2007 10:57 am

I tried both options and the extra source references still appear, they also show as: Only source reference for this field.

However, I found that it is doing it because there is no date in the proceeding record, below is the same person exported but this time I put dates in for christening and death (shown in bold) and the source references now show correctly (in red) for the previous field.

0 @I3369@ INDI
1 REFN 3369
1 NAME Ellen Betsy /HELM/
2 SOUR @S45@
3 QUAY 2
1 SEX F
1 BIRT
2 DATE 22 MAY 1843
2 SOUR @S45@
3 QUAY 2

1 CHR
2 DATE 1 JAN 1844
2 PLAC Hinchinbrooke, Beauharnois County, Quebec, Canada
2 SOUR @S45@
3 QUAY 2

1 DEAT
2 DATE 1 JAN 1890
2 PLAC California, USA
2 SOUR @S45@
3 QUAY 2
1 NOTE Living in Fresno, California, USA with her brother William Helm. 1870 Census.
1 FAMC @F1016@

Can the GEDCOM exporter be fixed so it doesn't produce an extra source reference when it doesn't find a date in the proceeding field?

Nick Hunter
Posts: 651
Joined: Sun Dec 18, 2005 9:36 am
Location: SpanSoft, Scotland
Contact:

Post by Nick Hunter » Wed Aug 08, 2007 11:41 am

Thanks for that. We are looking into this problem and hope to have a fix in a few days.

Nick Hunter
Posts: 651
Joined: Sun Dec 18, 2005 9:36 am
Location: SpanSoft, Scotland
Contact:

Post by Nick Hunter » Tue Aug 21, 2007 4:09 pm

This issue has now been resolved in K&KPro V2.1.3. Please use "Help | Check for updates" in K&KPro.

jayrae
Posts: 10
Joined: Sun Aug 13, 2006 12:19 am
Location: New Zealand

Post by jayrae » Thu Aug 23, 2007 10:02 am

Thanks for that, now works brilliantly!

Locked