Error Message - Invalid floating point operation

The old version of our genealogy database program.

Moderator: Nick Hunter

Locked
ColinT
Posts: 5
Joined: Thu Aug 03, 2006 8:38 pm
Location: Edinburgh, Scotland

Error Message - Invalid floating point operation

Post by ColinT » Fri Aug 04, 2006 8:09 am

Help.

When moving about the viewable screen, I keep getting an "Invalid floating point operation" error message. This only appears to happen in one area of the screen but as the program fails to draw the family rectangles, I cannot identify the offending record or records.

I assume that there is something wrong with the screen co-ordinates in one or more records but how do I recover from this?

I think the error first appeared just after I had completed a "Remove Duplicates" operation

Any answers out there?

ColinT

Nick Hunter
Posts: 663
Joined: Sun Dec 18, 2005 9:36 am
Location: SpanSoft, Scotland
Contact:

Post by Nick Hunter » Fri Aug 04, 2006 11:16 am

It's an unusual error.

As with all unusual errors first try "File | Database | Pack" then close down K&KPro and reopen.

If that doesn't help, then I think you're right about the problem being in the data somewhere.

Printing a Tree Layout report might help if there are connecting lines running off the edge of the report.

If you like, email to support@spansoft.org all the files from your database which begin "Families." and we will see if any have weird coordinates.

jayrae
Posts: 10
Joined: Sun Aug 13, 2006 12:19 am
Location: New Zealand

Post by jayrae » Sun Aug 13, 2006 12:27 am

Hello

I've had this error before, appears when there are a lot of families packed together on-screen in 1:1 view. The way I got rid of the error message was to spread-out the families (also makes the tree easier to follow), just get close to where the error occurs and move the families outwards.

JR.

Locked